Doom9 Italia

Forum Italiano di Doom9
Oggi è domenica 14 agosto 2022, 19:20

Tutti gli orari sono UTC+01:00




Apri un nuovo argomento  Rispondi all’argomento  [ 12 messaggi ]  Vai alla pagina 1 2 Prossimo
Autore Messaggio
 Oggetto del messaggio: Problemi riproduzione DIVX
MessaggioInviato: venerdì 8 aprile 2005, 20:17 
Non connesso

Iscritto il: martedì 1 marzo 2005, 22:55
Messaggi: 5
Ho 3 files avi con normalissivo video DIVX e audio mp3 cbr, che
riprodotti con un qualsiasi player per Win non danno nessun problema, ma quando li riroduco utilizzando il lettore DIVX (Samsung dvd p244) da tavolo il video va a scatti.
L' unico modo che ho trovato per farli funzionare correttamente anche sul
lettore e' stato quello di ricomprimerli con Virtualdubmod ma la qualita'
del video cala pesantemente.
Qualcuno di voi ha per caso avuto lo stesso problema ed e' riuscito a
risolverlo efficacemente?




GEN


Top
   
 Oggetto del messaggio: Re: Problemi riproduzione DIVX
MessaggioInviato: venerdì 8 aprile 2005, 20:49 
Non connesso
Moderatore
Avatar utente

Iscritto il: giovedì 19 giugno 2003, 13:18
Messaggi: 230
Località: EU (Italy)
Tafano wrote:
> Ho 3 files avi con normalissivo video DIVX [...]

Se non definisci "normalissimo" penso che solo la Maga Ornella sapra' risponderti. ;)
E' meglio se posti qualche screenshot di GSpot.

Ah... :idea: Visto che saranno le riprese delle comunioni e delle cresime dei tuoi figli e dei tuoi nipoti, ti suggerisco di rinominare in modo generico tali AVI, cosi' da tutelare la privacy della tua famiglia.



Quando si parla di video a scatti, mi vien da dire che la causa sia il packed bitstream... solo che in teoria il tuo player non dovrebbe risentirne.

Se per assurdo dovesse essere proprio questo il problema (dagli screenshot di GSpot si fara' presto a vederlo), sappi che risolvero e' semplice ed indolore.
Basta infatti aprire l'AVI con MPEG4 Modifier ed usare l'apposita opzione per eliminare il packed bitstream (senza ricodificare e quindi senza perdere qualita'... ma guadagnando pure qualche KiB).

_________________
"In 18 anni non ero mai servita a nessuno, ma qui posso aiutare e persino essere necessaria agli altri."
.hack//SIGN special - Intermezzo


Top
   
 Oggetto del messaggio:
MessaggioInviato: sabato 9 aprile 2005, 14:07 
Non connesso

Iscritto il: martedì 1 marzo 2005, 22:55
Messaggi: 5
Ecco cosa dice Gspot:

- Codec video: 4CC DX50/divx, DivX 5.0
- Stream type: AVI, IMRR 1.00, I/L => 1 aud frame (24 ms), Split: Yes

per i 2 che danno meno problemi;


- Codec video: 4CC DIVX/xvid, DivX 4 (OpenDivX)
- Stream type: OpenDML AVI, IMRR 1.00, I/L => 1 vid frame (42 ms),
p=496, Split: No

per quello che va peggio.

Ho provato a eliminare il packed bitstream con MPEG4 Modifier ma non cambia niente. Per la cronaca ho provato anche a usare i filtri avi import di Virtualdub selezionando l' opzione Rekeying video stream ma il programma crasha dopo aver aperto meta' abbondante del file.

Cosa posso fare adesso?

Grazie.





GEN


Top
   
 Oggetto del messaggio:
MessaggioInviato: sabato 9 aprile 2005, 20:29 
Non connesso
Moderatore
Avatar utente

Iscritto il: giovedì 19 giugno 2003, 13:18
Messaggi: 230
Località: EU (Italy)
Tafano wrote:
> Ecco cosa dice Gspot:
> [...]

Veramente quando ho scritto "screenshot" non era un modo di dire...
Volendo potresti anche esportare un log testuale, ma lo screenshot sarebbe di certo piu' leggibile. ;)


Riguardo a quello che c'hai indicato, se sia un problema d'interlave non saprei dirtelo (puoi fare la prova del nove aprendo il file con VirtualDubMod e risalvandolo come AVI, settando il video a direct stream copy in modo che non venga ricompresso).

Penso pero' che il tuo problema riguardi piu' che altro le opzioni di codifica che sono state usate per generare il video: in questo caso potresti solo cercare di minimizzare la perdita di qualita' quando andrai a ricomprimere il video.

_________________
"In 18 anni non ero mai servita a nessuno, ma qui posso aiutare e persino essere necessaria agli altri."
.hack//SIGN special - Intermezzo


Top
   
 Oggetto del messaggio:
MessaggioInviato: domenica 10 aprile 2005, 20:16 
Non connesso
Avatar utente

Iscritto il: venerdì 4 febbraio 2005, 17:18
Messaggi: 63
Non conosco le specifiche del tuo lettore da tavolo ma alcuni avvertimenti sono sempre utili:
non attivare MAI il GMC o il QPEL, limita il numero dei B-Frames a 1, se usi Xvid attiva sempre il packed bitstream (in DivX e' automatico), assicurati di impostare il profilo Home Theater (sia in DivX che in Xvid - se usi la versione 1.1 beta) e se usi Xvid cerca di usare solo h.263 o MPEG matrix.
Se i filmati in tuo possesso sono stati codificati tralasciando le precedenti specifiche non è detto che siano riproducibili correttamente su un lettore da tavolo (non lo sono quasi mai...) e l'unica soluzione e ricomprimerli facendo attenzione a quanto ho appena scritto.


Top
   
 Oggetto del messaggio:
MessaggioInviato: domenica 10 aprile 2005, 21:22 
Non connesso
Moderatore
Avatar utente

Iscritto il: giovedì 19 giugno 2003, 13:18
Messaggi: 230
Località: EU (Italy)
Tooth wrote:
> non attivare MAI il GMC [...]

GMC viene supportato dai lettori con chipset Mediatek e quando possibile e' sempre meglio usarlo.


Tooth also wrote:
> [...] attiva sempre il packed bitstream [...]

Mi auguro tu volessi dire "disattiva"! :P
E' una funzione quasi del tutto inutile (se non per l'editing) e la digeriscono senza problemi solo i chipset ESS (anche i Zoran Vaddis han problemi).

_________________
"In 18 anni non ero mai servita a nessuno, ma qui posso aiutare e persino essere necessaria agli altri."
.hack//SIGN special - Intermezzo


Top
   
 Oggetto del messaggio:
MessaggioInviato: lunedì 11 aprile 2005, 3:11 
Non connesso
Avatar utente

Iscritto il: venerdì 4 febbraio 2005, 17:18
Messaggi: 63
Cita:
Tooth wrote:
> non attivare MAI il GMC [...]

GMC viene supportato dai lettori con chipset Mediatek e quando possibile e' sempre meglio usarlo.
No. Il GMC non è nelle specifiche del profilo Divx Home Theater, inoltre il GMC di Xvid (3WP) attualmente non è riproducibile in nessun lettore da tavolo (compresi quelli che sono "compatibili" con il GMC di DivX).
Inoltre svariati test fatti dai numerosi membri del forum di doom9.org (me compreso) dimostrano che il GMC aumenta la complessità della decodifica, ma il guadagno a livello di comprimibilità (per Xvid e NeroDigital-ASP) è pressochè nullo ed inesistente nel caso di DivX, che ha un GMC ad 1 solo warp point (= inutile e forse anche nocivo a livello di compressione!)
Il GMC è stato anche "eliminato" dall'MPEG-4 V10 (AVC) perchè si è visto che è praticamente inutile...
Cita:
Tooth wrote:
> [...] attiva sempre il packed bitstream [...]

Mi auguro tu volessi dire "disattiva"! :P
E' una funzione quasi del tutto inutile (se non per l'editing) e la digeriscono senza problemi solo i chipset ESS (anche i Zoran Vaddis han problemi).
Anche qui ti sbagli. Il packed bitstream è obbligatorio perchè lo stream video sia compatibile con il profilo DivX Home Theatre.
Cmq sia DivX Network sta valutando di ritoccare questo particolare nella prossima versione (DivX 6) proprio perchè alcuni lettori hanno problemi con il packed bitstream, ma per rimanere pienamente aderenti con le specifiche del profilo ed assicurare un playback corretto in tutti i lettori certificati DivX, è necessario settare max 1-bframe e abilitare il packed bitstream.
Per quanto riguarda i lettori capaci di decodificare 2 o più b-frames la situazione è opposta ed è necessario disabilitare il packed bitstream.


Top
   
 Oggetto del messaggio:
MessaggioInviato: lunedì 11 aprile 2005, 18:41 
Non connesso

Iscritto il: martedì 1 marzo 2005, 22:55
Messaggi: 5
Ho ricompresso il file in condizioni peggiori con Virtualdub utilizzando il codec XVID (che sembra quello nativo del file) attivando anche il Qpel, i risultati non sono stati affatto male e probabilmente inserendo qualche buon filtro per il video otterrei quasi la stessa qualita' del file di partenza. Ho provato a ricomprimerlo anche utilizzando il codec DIVX ma i risultati non sono stati altrettanto buoni.
Da notare che per i 2 files in condizioni migliori i problemi del video che va a scatti si presentano all' inizio della riproduzione, nei primi 5/10 secondi, poi per tutto il resto del filmato sia le immagini che i suoni si mantengono buoni.



GEN


Top
   
 Oggetto del messaggio:
MessaggioInviato: lunedì 11 aprile 2005, 20:46 
Non connesso
Avatar utente

Iscritto il: venerdì 4 febbraio 2005, 17:18
Messaggi: 63
Bene, quindi il tuo lettore sembra che supporti il QPEL.
Che impostazioni hai usato per i b-frames ecc ecc?


Top
   
 Oggetto del messaggio:
MessaggioInviato: lunedì 11 aprile 2005, 22:37 
Non connesso

Iscritto il: martedì 1 marzo 2005, 22:55
Messaggi: 5
Le uniche cose che ho cambiato nel profilo XVID sono spuntato la casella Quarter Pixel e selezionato MPEG come Quantization Type.
Per il resto ho lasciato invariati i valori nella tabella B-VOPs con Packed Bitstream e Closed GOV selezionati.





GEN


Top
   
Visualizza ultimi messaggi:  Ordina per  
Apri un nuovo argomento  Rispondi all’argomento  [ 12 messaggi ]  Vai alla pagina 1 2 Prossimo

Tutti gli orari sono UTC+01:00


Chi c’è in linea

Visitano il forum: Nessuno e 0 ospiti


Non puoi aprire nuovi argomenti
Non puoi rispondere negli argomenti
Non puoi modificare i tuoi messaggi
Non puoi cancellare i tuoi messaggi
Non puoi inviare allegati

Cerca per:
Vai a:  
cron
Creato da phpBB® Forum Software © phpBB Limited
Traduzione Italiana phpBB-Italia.it